forum.alglib.net

ALGLIB forum
It is currently Sun Oct 20, 2019 2:21 pm

All times are UTC


Forum rules


1. This forum can be used for discussion of both ALGLIB-related and general numerical analysis questions
2. This forum is English-only - postings in other languages will be removed.



Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: dforest tests in test_c fail, but falsely report success.
PostPosted: Tue Mar 05, 2019 9:20 pm 
Offline

Joined: Mon Nov 20, 2017 11:14 pm
Posts: 16
The calculation of avgce in the dforest test routines does not match what the algorithms, themselves, in the dforest module, do. Therefore, some of the dforest tests actually fail, even though they appear to pass.

Your test routines falsely report success, because in your ae_set_error_flag(), which sets the negative of a flag, you treat (A <= B) and (A > B); (A >= B) and (A < B) as negatives of one another, which they are not when A or B is NAN or INFINITY. So, a failure may pass through unseen, when A or B are NAN or INFINITY. This is what happens here.

The problem is removed by changing the calculation of avgce in test_c so that it matches how dforest module calculates avgce.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group